Skip to content
Example repo for gatsby issue #13707
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
.circleci
common
packages
site-pinned-version
site-star-version
.gitattributes
.gitignore
README.md
rush.json

README.md

gatsby-13707

Example repo for https://github.com/gatsbyjs/gatsby/issues/13707

CircleCI

Suspected Problems

  • Rush relies on using symlinks to allow consuming local versions of packages that exist in the monorepo
  • Rush also relies on a version set in the consuming package (non *) so that it can know whether to link or pull an older version from NPM
  • Gatsby seems to by idiom rely on the theme package having "*" or is unable to follow the symlinks to the local versions of theme packages

Local Install Instructions

  • npm install -g @microsoft/rush
  • nvm use 10.15 (Rush requires Node version >=8.9.4 < 11.0.0)
  • rush install
  • rush build
You can’t perform that action at this time.