Skip to content

Cross-Site Scripting in sanitize-html

Moderate severity GitHub Reviewed Published Apr 16, 2020 to the GitHub Advisory Database • Updated Jan 9, 2023

Package

npm sanitize-html (npm)

Affected versions

< 1.4.3

Patched versions

1.4.3

Description

Affected versions of sanitize-html do not sanitize input recursively, which may allow an attacker to execute arbitrary Javascript.

Recommendation

Update to version 1.4.3 or later.

References

Reviewed Apr 16, 2020
Published to the GitHub Advisory Database Apr 16, 2020
Last updated Jan 9, 2023

Severity

Moderate
6.1
/ 10

CVSS base metrics

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
Required
Scope
Changed
Confidentiality
Low
Integrity
Low
Availability
None
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Weaknesses

CVE ID

CVE-2016-1000237

GHSA ID

GHSA-3j7m-hmh3-9jmp

Source code

No known source code
Checking history
See something to contribute? Suggest improvements for this vulnerability.