Skip to content

Prototype Pollution in lodash

high severity Published Feb 7, 2019 • Updated Jan 8, 2021

Package

npm lodash (npm)

Affected versions

< 4.17.11

Patched versions

4.17.11

Description

Versions of lodash before 4.17.5 are vulnerable to prototype pollution.

The vulnerable functions are 'defaultsDeep', 'merge', and 'mergeWith' which allow a malicious user to modify the prototype of Object via {constructor: {prototype: {...}}} causing the addition or modification of an existing property that will exist on all objects.

Recommendation

Update to version 4.17.11 or later.

References

CVE ID

CVE-2018-16487