Skip to content

codecov NPM module allows remote attackers to execute arbitrary commands

high severity Published Feb 19, 2020 • Updated Aug 19, 2021

Package

npm codecov (npm)

Affected versions

< 3.6.5

Patched versions

3.6.5

Description

codecov-node npm module before 3.6.5 allows remote attackers to execute arbitrary commands.The value provided as part of the gcov-root argument is executed by the exec function within lib/codecov.js. This vulnerability exists due to an incomplete fix of CVE-2020-7596.

References

CVE ID

CVE-2020-7597

CVSS Score

8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H