Skip to content

Denial of Service in @commercial/hapi

High severity GitHub Reviewed Published Sep 3, 2020 to the GitHub Advisory Database • Updated Jan 9, 2023

Package

npm @commercial/hapi (npm)

Affected versions

< 16.8.2
>= 17.0.0, < 17.9.2
>= 18.0.0, < 18.4.1
>= 19.0.0, < 19.1.1

Patched versions

16.8.2
17.9.2
18.4.1
19.1.1

Description

Affected versions of @commercial/hapi are vulnerable to Denial of Service. The CORS request handler has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.

Recommendation

Upgrade to versions 16.8.2, 17.9.2, 18.4.1, 19.1.1 or later.

References

Reviewed Aug 31, 2020
Published to the GitHub Advisory Database Sep 3, 2020
Last updated Jan 9, 2023

Severity

High

Weaknesses

No CWEs

CVE ID

No known CVE

GHSA ID

GHSA-66mv-xh68-h6v2

Source code

No known source code
Checking history
See something to contribute? Suggest improvements for this vulnerability.