Skip to content

XSS in jQuery as used in Drupal, Backdrop CMS, and other products

moderate severity Published Apr 26, 2019 • Updated Oct 21, 2021

Package

npm jquery (npm)

Affected versions

< 3.4.0

Patched versions

3.4.0

Description

jQuery before 3.4.0, as used in Drupal, Backdrop CMS, and other products, mishandles jQuery.extend(true, {}, ...) because of Object.prototype pollution. If an unsanitized source object contained an enumerable proto property, it could extend the native Object.prototype.

References

CVE ID

CVE-2019-11358

CVSS Score

6.1 Moderate
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N