Skip to content

gfe-sass downloads Resources over HTTP

High severity GitHub Reviewed Published Sep 1, 2020 to the GitHub Advisory Database • Updated Sep 11, 2023

Package

npm gfe-sass (npm)

Affected versions

>= 0.0.0

Patched versions

None

Description

Affected versions of gfe-sass insecurely download an executable over an unencrypted HTTP connection.

In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running gfe-sass.

Recommendation

No patch is currently available for this vulnerability.

The best mitigation is currently to avoid using this package, using a different package if available.

Alternatively, the risk of exploitation can be reduced by ensuring that this package is not installed while connected to a public network. If the package is installed on a private network, the only people who can exploit this vulnerability are those who have compromised your network or those who have privileged access to your ISP, such as Nation State Actors or Rogue ISP Employees.

References

Reviewed Aug 31, 2020
Published to the GitHub Advisory Database Sep 1, 2020
Last updated Sep 11, 2023

Severity

High
8.1
/ 10

CVSS base metrics

Attack vector
Network
Attack complexity
High
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Weaknesses

CVE ID

CVE-2017-16040

GHSA ID

GHSA-72q2-5rxx-xfff

Source code

No known source code
Checking history
See something to contribute? Suggest improvements for this vulnerability.