Skip to content

Denial of Service in hapi

high severity Published Sep 3, 2020

Package

npm hapi (npm)

Affected versions

>= 0.0.0

Patched versions

None

Description

All Versions of hapi are vulnerable to Denial of Service. The CORS request handler has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.

Recommendation

This package is deprecated and is now maintained as @hapi/hapi. Please update your dependencies to use @hapi/hapi.

References

GHSA ID

GHSA-7hx8-2rxv-66xv