Skip to content

Regular Expression Denial of Service in trim-newlines

high severity Published Jun 7, 2021 • Updated Jun 7, 2021
We are still processing this advisory. You may have affected repositories that are not yet on this list. Check back soon for more.

Package

npm trim-newlines (npm)

Affected versions

< 3.0.1
= 4.0.0

Patched versions

3.0.1
4.0.1

Description

The trim-newlines package before 3.0.1 and 4.x before 4.0.1 for Node.js has an issue related to regular expression denial-of-service (ReDoS) for the .end() method.

References

CVE ID

CVE-2021-33623

CVSS Score

7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H