Skip to content

Potential Remote Code Execution vulnerability

High severity GitHub Reviewed Published Oct 1, 2020 in nette/application • Updated Feb 1, 2023

Package

composer nette/application (Composer)

Affected versions

>= 2.2.0, < 2.2.10
>= 2.3.0, < 2.3.14
>= 2.4.0, < 2.4.16
>= 3.0.0, < 3.0.6
>= 2.0.0, < 2.0.19
>= 2.1.0, < 2.1.13

Patched versions

2.2.10
2.3.14
2.4.16
3.0.6
2.0.19
2.1.13

Description

Packages nette/application versions prior to 2.2.10, 2.3.14, 2.4.16, 3.0.6 and nette/nette versions prior to 2.0.19 and 2.1.13 are vulnerable to an code injection attack by passing specially formed parameters to URL that may possibly leading to RCE.

Reported by Cyku Hong from DEVCORE (https://devco.re)

Impact

Code injection, possible remote code execution.

Patches

Fixed in nette/application 2.2.10, 2.3.14, 2.4.16, 3.0.6 and nette/nette 2.0.19 and 2.1.13

References

Last updated Feb 1, 2023
Published to the GitHub Advisory Database Oct 2, 2020
Published by the National Vulnerability Database Oct 1, 2020
Reviewed Oct 1, 2020
@dg dg published to nette/application Oct 1, 2020

Severity

High
8.7
/ 10

CVSS base metrics

Attack vector
Network
Attack complexity
High
Privileges required
None
User interaction
None
Scope
Changed
Confidentiality
High
Integrity
High
Availability
None
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N

CVE ID

CVE-2020-15227

GHSA ID

GHSA-8gv3-3j7f-wg94

Source code

Checking history
See something to contribute? Suggest improvements for this vulnerability.