Skip to content

Inefficient Regular Expression Complexity in chalk/ansi-regex

moderate severity Published Sep 20, 2021 • Updated Oct 6, 2021
We are still processing this advisory. You may have affected repositories that are not yet on this list. Check back soon for more.

Package

npm ansi-regex (npm)

Affected versions

>= 6.0.0, < 6.0.1
> 2.1.1, < 5.0.1

Patched versions

6.0.1
5.0.1

CVE ID

CVE-2021-3807

CVSS Score

7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H