Skip to content

Cross-Site Scripting in bootstrap

Moderate severity GitHub Reviewed Published Feb 22, 2019 • Updated May 26, 2022

Package

bundler bootstrap (RubyGems)

Affected versions

< 4.3.1

Patched versions

4.3.1
bundler bootstrap-sass (RubyGems)
>= 3.0.0, < 3.4.1
3.4.1

Description

Versions of bootstrap prior to 3.4.1 for 3.x and 4.3.1 for 4.x are vulnerable to Cross-Site Scripting (XSS). The data-template attribute of the tooltip and popover plugins lacks input sanitization and may allow attacker to execute arbitrary JavaScript.

Recommendation

For bootstrap 4.x upgrade to 4.3.1 or later.
For bootstrap 3.x upgrade to 3.4.1 or later.

References

Severity

Moderate
6.1
/ 10

CVSS base metrics

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
Required
Scope
Changed
Confidentiality
Low
Integrity
Low
Availability
None
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Weaknesses

CVE ID

CVE-2019-8331

GHSA ID

GHSA-9v3m-8fp8-mj99

Source code

No known source code
Checking history
See something to contribute? Suggest improvements for this vulnerability.