Skip to content

Path Traversal in algo-httpserv

High severity GitHub Reviewed Published Sep 11, 2019 to the GitHub Advisory Database • Updated Jan 9, 2023

Package

npm algo-httpserv (npm)

Affected versions

< 1.1.2

Patched versions

1.1.2

Description

Versions of algo-httpserv prior to 1.1.2 are vulnerable to Path Traversal. Due to insufficient input sanitization, attackers can access server files by using relative paths.

Recommendation

Upgrade to version 1.1.2 or later.

References

Last updated Jan 9, 2023
Published to the GitHub Advisory Database Sep 11, 2019
Reviewed Sep 3, 2019

Severity

High
8.6
/ 10

CVSS base metrics

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
Low
Availability
Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L

Weaknesses

CVE ID

No known CVE

GHSA ID

GHSA-cgjv-rghq-qhgp

Source code

No known source code
Checking history
See something to contribute? Suggest improvements for this vulnerability.