Skip to content

Prototype Pollution in dot-prop

High severity GitHub Reviewed Published Jul 29, 2020 • Updated Jan 4, 2022

Package

npm dot-prop (npm )

Affected versions

< 4.2.1
>= 5.0.0, < 5.1.1

Patched versions

4.2.1
5.1.1

Description

Prototype pollution vulnerability in dot-prop npm package versions before 4.2.1 and versions 5.x before 5.1.1 allows an attacker to add arbitrary properties to JavaScript language constructs such as objects.

References

Severity

High
7.3
/ 10

CVSS base metrics

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
Low
Integrity
Low
Availability
Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

CVE ID

CVE-2020-8116

GHSA ID

GHSA-ff7x-qrg7-qggm

Source code

See something to contribute? Suggest improvements for this vulnerability.