Skip to content

Incorrect Authorization in runc

High severity GitHub Reviewed Published Feb 22, 2022 to the GitHub Advisory Database • Updated May 20, 2024

Package

gomod github.com/opencontainers/runc (Go)

Affected versions

< 1.0.0-rc8.0.20190930145003-cad42f6e0932

Patched versions

1.0.0-rc8.0.20190930145003-cad42f6e0932
gomod github.com/opencontainers/selinux (Go)
< 1.3.1-0.20190929122143-5215b1806f52
1.3.1-0.20190929122143-5215b1806f52
Published by the National Vulnerability Database Sep 25, 2019
Published to the GitHub Advisory Database Feb 22, 2022
Reviewed Feb 22, 2022
Last updated May 20, 2024

Severity

High
7.5
/ 10

CVSS base metrics

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
None
Integrity
High
Availability
None
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Weaknesses

CVE ID

CVE-2019-16884

GHSA ID

GHSA-fgv8-vj5c-2ppq

Source code

Loading Checking history
See something to contribute? Suggest improvements for this vulnerability.