Skip to content

Prototype Pollution in handlebars

High severity GitHub Reviewed Published Sep 4, 2020 • Updated Oct 1, 2021

Package

npm handlebars (npm)

Affected versions

< 3.0.8
>= 4.0.0, < 4.5.3

Patched versions

3.0.8
4.5.3

Description

Versions of handlebars prior to 3.0.8 or 4.5.3 are vulnerable to prototype pollution. It is possible to add or modify properties to the Object prototype through a malicious template. This may allow attackers to crash the application or execute Arbitrary Code in specific conditions.

Recommendation

Upgrade to version 3.0.8, 4.5.3 or later.

References

Severity

High

Weaknesses

CVE ID

No known CVE

GHSA ID

GHSA-g9r4-xpmj-mj65

Source code

No known source code
Checking history
See something to contribute? Suggest improvements for this vulnerability.