Skip to content

Cross-Site Scripting in shave

Moderate severity GitHub Reviewed Published May 29, 2019 to the GitHub Advisory Database • Updated Jan 9, 2023

Package

npm shave (npm)

Affected versions

< 2.5.3

Patched versions

2.5.3

Description

Versions of shave prior to 2.5.3 are vulnerable to Cross-Site Scripting. The shave package overwrites HTML elements and in doing so fails to properly encode the output. If encoded HTML input is passed into shave the output will be decoded which may lead to Cross-Site Scripting.

Recommendation

Upgrade to version 2.5.3 or later.

References

Last updated Jan 9, 2023
Published to the GitHub Advisory Database May 29, 2019
Reviewed May 29, 2019

Severity

Moderate
6.1
/ 10

CVSS base metrics

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
Required
Scope
Changed
Confidentiality
Low
Integrity
Low
Availability
None
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Weaknesses

CVE ID

CVE-2019-12313

GHSA ID

GHSA-gh4g-3gm9-5wrq

Source code

No known source code
Checking history
See something to contribute? Suggest improvements for this vulnerability.