Skip to content

Denial of Service in @hapi/ammo

High severity GitHub Reviewed Published Sep 3, 2020 • Updated Aug 13, 2022

Package

npm @hapi/ammo (npm)

Affected versions

< 3.1.2
>= 4.0.0, < 5.0.1

Patched versions

3.1.2
5.0.1

Description

Versions of @hapi/ammo prior to 3.1.2 or 5.0.1 are vulnerable to Denial of Service. The Range HTTP header parser has a vulnerability which will cause the function to throw a system error if the header is set to an invalid value. Because hapi is not expecting the function to ever throw, the error is thrown all the way up the stack. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.

Recommendation

Upgrade to version 3.1.2 or 5.0.1.

References

Severity

High

Weaknesses

No CWEs

CVE ID

No known CVE

GHSA ID

GHSA-gjph-xf5q-6mfq

Source code

No known source code
Checking history
See something to contribute? Suggest improvements for this vulnerability.