Skip to content

Malicious Package in lodahs

High severity GitHub Reviewed Published Dec 16, 2019 • Updated Jul 28, 2021

Package

npm lodahs (npm)

Affected versions

>= 0.0.1

Patched versions

None

Description

All versions of this package contained malware. The package was designed to find and exfiltrate cryptocurrency wallets.

Recommendation

Any computer that has this package installed or running should be considered fully compromised. All secrets and keys stored on that computer should be rotated immediately from a different computer.

The package should be removed, but as full control of the computer may have been given to an outside entity, there is no guarantee that removing the package will remove all malicious software resulting from installing it.

References

Severity

High
8.8
/ 10

CVSS base metrics

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
Required
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Weaknesses

CVE ID

CVE-2019-19771

GHSA ID

GHSA-hm6q-r2jc-cpqh

Source code

No known source code
Checking history
See something to contribute? Suggest improvements for this vulnerability.