Skip to content

Remote Code Execution in node-os-utils

High severity GitHub Reviewed Published Jun 11, 2019 • Updated Aug 4, 2021

Package

npm node-os-utils (npm)

Affected versions

< 1.1.0

Patched versions

1.1.0

Description

Versions of node-os-utils prior to 1.1.0 are vulnerable to Remote Code Execution. Due to insufficient input validation an attacker could run arbitrary commands on the server thus rendering the package vulnerable to Remote Code Execution.

Recommendation

Upgrade to version 1.1.0 or later.

References

Severity

High
7.3
/ 10

CVSS base metrics

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
Low
Integrity
Low
Availability
Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Weaknesses

CVE ID

No known CVE

GHSA ID

GHSA-j9f8-8h89-j69x

Source code

No known source code
Checking history
See something to contribute? Suggest improvements for this vulnerability.