Skip to content

Regular Expression Denial of Service in tmpl

moderate severity Published Sep 20, 2021 • Updated Sep 27, 2021

Package

npm tmpl (npm)

Affected versions

< 1.0.5

Patched versions

1.0.5

Description

nodejs-tmpl is vulnerable to Inefficient Regular Expression Complexity which may lead to resource exhaustion.

References

CVE ID

CVE-2021-3777

CVSS Score

7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H