Skip to content

Machine-In-The-Middle in https-proxy-agent

moderate severity GitHub Reviewed Published Apr 16, 2020 • Updated Aug 23, 2021

Package

npm https-proxy-agent (npm)

Affected versions

< 2.2.3

Patched versions

2.2.3

Description

Versions of https-proxy-agent prior to 2.2.3 are vulnerable to Machine-In-The-Middle. The package fails to enforce TLS on the socket if the proxy server responds the to the request with a HTTP status different than 200. This allows an attacker with access to the proxy server to intercept unencrypted communications, which may include sensitive information such as credentials.

Recommendation

Upgrade to version 3.0.0 or 2.2.3.

References

GHSA ID

GHSA-pc5p-h8pf-mvwp

CVSS Score

6.1 Moderate
CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N/