Skip to content

netmask npm package vulnerable to octal input data

moderate severity Published Mar 29, 2021 • Updated Jun 9, 2021

Package

npm netmask (npm)

Affected versions

< 2.0.1

Patched versions

2.0.1

Description

The netmask package before 2.0.1 for Node.js mishandles certain unexpected characters in an IP address string, such as an octal digit of 9. This (in some situations) allows attackers to bypass access control that is based on IP addresses. NOTE: this issue exists because of an incomplete fix for CVE-2021-28918.

References

CVE ID

CVE-2021-29418

CVSS Score

5.3 Moderate
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N