Navigation Menu

Skip to content

Embedded malware in ua-parser-js

High severity GitHub Reviewed Published Oct 22, 2021 to the GitHub Advisory Database • Updated Jul 28, 2023

Package

npm ua-parser-js (npm)

Affected versions

= 0.7.29
= 0.8.0
= 1.0.0

Patched versions

0.7.30
0.8.1
1.0.1

Description

The npm package ua-parser-js had three versions published with malicious code. Users of affected versions (0.7.29, 0.8.0, 1.0.0) should upgrade as soon as possible and check their systems for suspicious activity. See this issue for details as they unfold.

Any computer that has this package installed or running should be considered fully compromised. All secrets and keys stored on that computer should be rotated immediately from a different computer. The package should be removed, but as full control of the computer may have been given to an outside entity, there is no guarantee that removing the package will remove all malicious software resulting from installing it.

References

Reviewed Oct 22, 2021
Published to the GitHub Advisory Database Oct 22, 2021
Last updated Jul 28, 2023

Severity

High
8.8
/ 10

CVSS base metrics

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
Required
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE ID

No known CVE

GHSA ID

GHSA-pjwm-rvh2-c87w

Credits

Checking history
See something to contribute? Suggest improvements for this vulnerability.