Skip to content

Improper Verification of Cryptographic Signature in PySAML2

High severity GitHub Reviewed Published May 6, 2020 to the GitHub Advisory Database • Updated Sep 5, 2023

Package

pip pysaml2 (pip)

Affected versions

< 5.0.0

Patched versions

5.0.0

Description

PySAML2 before 5.0.0 does not check that the signature in a SAML document is enveloped and thus signature wrapping is effective, i.e., it is affected by XML Signature Wrapping (XSW). The signature information and the node/object that is signed can be in different places and thus the signature verification will succeed, but the wrong data will be used. This specifically affects the verification of assertions that have been signed.

References

Published by the National Vulnerability Database Jan 13, 2020
Reviewed May 6, 2020
Published to the GitHub Advisory Database May 6, 2020
Last updated Sep 5, 2023

Severity

High
7.5
/ 10

CVSS base metrics

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
None
Integrity
High
Availability
None
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Weaknesses

CVE ID

CVE-2020-5390

GHSA ID

GHSA-qf7v-8hj3-4xw7

Source code

No known source code
Checking history
See something to contribute? Suggest improvements for this vulnerability.