Skip to content

Inefficient Regular Expression Complexity in validator.js

moderate severity Published Nov 3, 2021

Package

npm validator (npm)

Affected versions

< 13.7.0

Patched versions

13.7.0

Description

validator.js prior to 13.7.0 is vulnerable to Inefficient Regular Expression Complexity

References

CVE ID

CVE-2021-3765

CVSS Score

5.3 Moderate
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L