Skip to content

Prototype Pollution in minimist

moderate severity Published Apr 3, 2020 • Updated Jul 28, 2021

Package

npm minimist (npm)

Affected versions

< 0.2.1
>= 1.0.0, < 1.2.3

Patched versions

0.2.1
1.2.3

Description

Affected versions of minimist are vulnerable to prototype pollution. Arguments are not properly sanitized, allowing an attacker to modify the prototype of Object, causing the addition or modification of an existing property that will exist on all objects.
Parsing the argument --__proto__.y=Polluted adds a y property with value Polluted to all objects. The argument --__proto__=Polluted raises and uncaught error and crashes the application.
This is exploitable if attackers have control over the arguments being passed to minimist.

Recommendation

Upgrade to versions 0.2.1, 1.2.3 or later.

References

CVE ID

CVE-2020-7598

CVSS Score

5.6 Moderate
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L