New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Brewing strigi fails while linking #42

Closed
nerdinand opened this Issue Oct 5, 2014 · 3 comments

Comments

Projects
None yet
3 participants
@nerdinand
Contributor

nerdinand commented Oct 5, 2014

Undefined symbols for architecture x86_64:
"lucene::util::atomic_threads::atomic_decrement(unsigned int_)", referenced from:
indexdump(char const_) in indexdump.cpp.o
ld: symbol(s) not found for architecture x86_64

Linking CXX shared module strigiindex_cluceneng.so
Undefined symbols for architecture x86_64:
"lucene::util::atomic_threads::atomic_decrement(unsigned int_)", referenced from:
CLuceneIndexReader::Private::createSingleFieldQuery(std::__1::basic_string<char, std::__1::char_traits, std::__1::allocator > const&, Strigi::Query const&) in cluceneindexreader.cpp.o
CLuceneIndexReader::documentId(std::__1::basic_string<char, std::__1::char_traits, std::__1::allocator > const&) in cluceneindexreader.cpp.o
CLuceneIndexReader::keywords(std::__1::basic_string<char, std::__1::char_traits, std::__1::allocator > const&, std::__1::vector<std::__1::basic_string<char, std::__1::char_traits, std::__1::allocator >, std::__1::allocator<std::__1::basic_string<char, std::__1::char_traits, std::__1::allocator > > > const&, unsigned int, unsigned int) in cluceneindexreader.cpp.o
CLuceneIndexWriter::deleteEntry(std::__1::basic_string<char, std::__1::char_traits, std::_1::allocator > const&, lucene::index::IndexWriter, lucene::index::IndexReader*) in cluceneindexwriter.cpp.o
ld: symbol(s) not found for architecture x86_64

@nerdinand

This comment has been minimized.

Show comment
Hide comment
@nerdinand

nerdinand Oct 15, 2014

Contributor

For the record: I got strigi to compile by changing the upstream clucene formula, adding this patch:

patch do
  url "http://sourceforge.net/p/clucene/bugs/_discuss/thread/ec8f649d/1024/attachment/0001-Fix-.pc-file-by-adding-clucene-shared-library.patch"
  sha1 "f3cd7272df8e258ee5bd8183b3d0c0f87d02b34d"
end

and compiling it with brew reinstall clucene --build-from-source. Not sure whether this patch should be applied to the upstream clucene formula...

Contributor

nerdinand commented Oct 15, 2014

For the record: I got strigi to compile by changing the upstream clucene formula, adding this patch:

patch do
  url "http://sourceforge.net/p/clucene/bugs/_discuss/thread/ec8f649d/1024/attachment/0001-Fix-.pc-file-by-adding-clucene-shared-library.patch"
  sha1 "f3cd7272df8e258ee5bd8183b3d0c0f87d02b34d"
end

and compiling it with brew reinstall clucene --build-from-source. Not sure whether this patch should be applied to the upstream clucene formula...

@miked63017

This comment has been minimized.

Show comment
Hide comment
@miked63017

miked63017 Nov 3, 2014

Thanks for this, looking everywhere for solution and this worked.

miked63017 commented Nov 3, 2014

Thanks for this, looking everywhere for solution and this worked.

@adymo

This comment has been minimized.

Show comment
Hide comment
@adymo

adymo Nov 11, 2014

Owner

Fixed by patching strigi itself.

Owner

adymo commented Nov 11, 2014

Fixed by patching strigi itself.

@adymo adymo closed this Nov 11, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment