Deprecation under rails 3.1 #6

Godisemo opened this Issue Sep 7, 2011 · 1 comment


None yet

2 participants


I get this warning when using this plugin with rails 3.1

DEPRECATION WARNING: class_inheritable_attribute is deprecated, please use class_attribute method instead. Notice their behavior are slightly different, so refer to class_attribute documentation first. (called from block in <top (required)> at /Users/[...]/config/initializers/active_enum.rb:4

Where the row causing the error is

config.extend_classes = [ ActiveRecord::Base ]

My configuration in full looks like

require 'active_enum/form_helpers/simple_form'

ActiveEnum.setup do |config|
  config.extend_classes = [ ActiveRecord::Base ]

I have fixed this in 0.9.4 which I just pushed. Thanks.

@adzap adzap closed this Sep 8, 2011
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment