Permalink
Browse files

explicitly require ar_mailer until I understand why its not loaded by

environment for the namedspaced gem (ie adzap)
  • Loading branch information...
adzap committed Jul 6, 2009
1 parent c2fa208 commit 335f7cac4d4b1a747eeb278ba60dda35af5b4b9d
Showing with 5 additions and 2 deletions.
  1. +5 −2 lib/action_mailer/ar_sendmail.rb
@@ -3,6 +3,11 @@
require 'smtp_tls' unless Net::SMTP.instance_methods.include?("enable_starttls_auto")
require 'rubygems'
+module ActionMailer; end
+# This should get loaded by the environment later but for some reason fails with
+# the github namespaced gem and succeeds with a local gem build install.
+require 'action_mailer/ar_mailer'
+
##
# Hack in RSET
@@ -36,8 +41,6 @@ def reset
# * --daemon
# * --mailq
-module ActionMailer; end
-
class ActionMailer::ARSendmail
##

0 comments on commit 335f7ca

Please sign in to comment.