Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Fix the require thread issue for ActiveSupport for newer rubygems

  • Loading branch information...
commit 1254ae8d8fff12a8c90fe614d26534c6430792fd 1 parent 4e38fef
@adzap authored
View
5 History.txt
@@ -1,3 +1,8 @@
+= 2.1.10
+
+* Bugs fixed
+ * Fix require 'thread' for newer version of Rubygems (groan)
+
= 2.1.9
* Merged in minimal environment load option (experimental)
View
2  adzap-ar_mailer.gemspec
@@ -2,7 +2,7 @@
Gem::Specification.new do |s|
s.name = %q{adzap-ar_mailer}
- s.version = "2.1.9"
+ s.version = "2.1.10"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Eric Hodel", "Adam Meehan"]
View
3  lib/action_mailer/ar_sendmail.rb
@@ -45,7 +45,7 @@ class MinimalEnvironmentFailed < StandardError; end
##
# The version of ActionMailer::ARSendmail you are running.
- VERSION = '2.1.9'
+ VERSION = '2.1.10'
##
# Maximum number of times authentication will be consecutively retried
@@ -288,6 +288,7 @@ def self.load_rails_environment(base_path)
def self.load_minimal_environment(base_path)
Dir.chdir(base_path) do
Dir.glob('vendor/rails/*/lib').each { |dir| $:.unshift File.expand_path(dir) }
+ require 'thread'
require 'yaml'
require 'erb'
require 'active_record'
Please sign in to comment.
Something went wrong with that request. Please try again.