Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Added versions for gem dependencies and updated gemspec once again.

  • Loading branch information...
commit 6f4d64809082f5b3a6fe2af3e9d14dee2d494834 1 parent d460caa
@aef authored
Showing with 16 additions and 12 deletions.
  1. +6 −2 Rakefile
  2. +10 −10 linebreak.gemspec
View
8 Rakefile
@@ -7,8 +7,12 @@ Hoe.spec('linebreak') do
developer('Alexander E. Fischer', 'aef@raxys.net')
self.rubyforge_name = 'linebreak'
- self.extra_dev_deps = %w{user-choices rspec popen4}
- self.url = 'https://rubyforge.org/projects/aef/'
+ self.extra_dev_deps = {
+ 'user-choices' => '>= 1.1.6',
+ 'rspec' => '>= 1.2.8',
+ 'popen4' => '>= 0.1.2'
+ }
+ self.url = 'https://rubyforge.org/projects/linebreak/'
self.readme_file = 'README.rdoc'
self.extra_rdoc_files = %w{README.rdoc}
self.spec_extras = {
View
20 linebreak.gemspec
@@ -14,7 +14,7 @@ between linebreak encoding formats of unix, windows or mac.}
s.executables = ["linebreak"]
s.extra_rdoc_files = ["History.txt", "Manifest.txt", "COPYING.txt", "README.rdoc"]
s.files = ["History.txt", "Manifest.txt", "README.rdoc", "COPYING.txt", "Rakefile", "bin/linebreak", "lib/aef/linebreak.rb", "lib/aef/linebreak/string_extension.rb", "lib/aef/linebreak/commands/encode.rb", "lib/aef/linebreak/commands/encodings.rb", "lib/aef/linebreak/commands/version.rb", "lib/aef/linebreak/pathname_conversion.rb", "lib/aef/linebreak/linebreak.rb", "spec/spec_helper.rb", "spec/linebreak_spec.rb", "spec/spec.opts", "spec/fixtures/unix.txt", "spec/fixtures/windows.txt", "spec/fixtures/mac.txt", "spec/fixtures/unix_windows.txt", "spec/fixtures/windows_mac.txt", "spec/fixtures/mac_unix.txt", "spec/fixtures/unix_windows_mac.txt"]
- s.homepage = %q{https://rubyforge.org/projects/aef/}
+ s.homepage = %q{https://rubyforge.org/projects/linebreak/}
s.rdoc_options = ["--main", "README.rdoc", "--inline-source", "--line-numbers", "--title", "Linebreak"]
s.require_paths = ["lib"]
s.rubyforge_project = %q{linebreak}
@@ -26,20 +26,20 @@ between linebreak encoding formats of unix, windows or mac.}
s.specification_version = 3
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<user-choices>, [">= 0"])
- s.add_development_dependency(%q<rspec>, [">= 0"])
- s.add_development_dependency(%q<popen4>, [">= 0"])
+ s.add_development_dependency(%q<rspec>, [">= 1.2.8"])
+ s.add_development_dependency(%q<popen4>, [">= 0.1.2"])
+ s.add_development_dependency(%q<user-choices>, [">= 1.1.6"])
s.add_development_dependency(%q<hoe>, [">= 2.3.2"])
else
- s.add_dependency(%q<user-choices>, [">= 0"])
- s.add_dependency(%q<rspec>, [">= 0"])
- s.add_dependency(%q<popen4>, [">= 0"])
+ s.add_dependency(%q<rspec>, [">= 1.2.8"])
+ s.add_dependency(%q<popen4>, [">= 0.1.2"])
+ s.add_dependency(%q<user-choices>, [">= 1.1.6"])
s.add_dependency(%q<hoe>, [">= 2.3.2"])
end
else
- s.add_dependency(%q<user-choices>, [">= 0"])
- s.add_dependency(%q<rspec>, [">= 0"])
- s.add_dependency(%q<popen4>, [">= 0"])
+ s.add_dependency(%q<rspec>, [">= 1.2.8"])
+ s.add_dependency(%q<popen4>, [">= 0.1.2"])
+ s.add_dependency(%q<user-choices>, [">= 1.1.6"])
s.add_dependency(%q<hoe>, [">= 2.3.2"])
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.