Test if your Windows is vulnerable for the Spectre/Meltdown exploit
Clone or download
Latest commit a010f70 Dec 8, 2018

README.md

cpp-spectre-meltdown-vulnerability-windows-test

Test if your Windows is vulnerable for the Spectre/Meltdown exploit

alt text

About

If the program is able to read the string and display the string vertically, you are vulnerable for the exploit!

Expected behavior

  • Output, the system is vulrenable for the exploit

alt text

  • if you can see this, your system is vulrenable.

System requirements

  • SSE2 capable processor (the program crashes without)

Tested on

  • Windows 10 with no problems
  • an up to date Windows 7 with no problems

Compiling

Use CodeBlock 13.12 or GNU C++ Compiler with parameters: -STD=C99 -MSSE2

Credits

https://www.exploit-db.com/exploits/43427/

me for just making the Windows/GNUC++ version/binaries

-- Steffan