Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Tree: 0e974aec72
Fetching contributors…

Cannot retrieve contributors at this time

executable file 133 lines (133 sloc) 3.9 kB
<project>
<modelVersion>4.0.0</modelVersion>
<groupId>com.guidewire</groupId>
<artifactId>my_app</artifactId>
<version>1.0-SNAPSHOT</version>
<packaging>jar</packaging>
<name>my_app</name>
<parent>
<groupId>org.gosu-lang</groupId>
<artifactId>gosu-project-parent</artifactId>
<version>4</version>
</parent>
<repositories>
<repository>
<id>gosu-lang.org-releases</id>
<name>Official Gosu website (releases)</name>
<url>http://gosu-lang.org/nexus/content/groups/releases</url>
</repository>
</repositories>
<dependencies>
<dependency>
<groupId>org.gosu-lang.ronin</groupId>
<artifactId>ronin-ws</artifactId>
<version>0.5-SNAPSHOT</version>
</dependency>
<dependency>
<groupId>org.gosu-lang.ronin</groupId>
<artifactId>ronin-log</artifactId>
<version>0.9.5-3</version>
<scope>runtime</scope>
</dependency>
<dependency>
<groupId>org.gosu-lang.ronin</groupId>
<artifactId>ronin</artifactId>
<version>0.9.5-3</version>
</dependency>
<dependency>
<groupId>org.gosu-lang.tosa</groupId>
<artifactId>tosa-loader</artifactId>
<version>0.2</version>
</dependency>
<dependency>
<groupId>org.gosu-lang.tosa</groupId>
<artifactId>tosa-runtime</artifactId>
<version>0.2</version>
</dependency>
<dependency>
<groupId>com.h2database</groupId>
<artifactId>h2</artifactId>
<version>1.3.148</version>
<scope>runtime</scope>
</dependency>
<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-server</artifactId>
<version>8.0.0.M2</version>
<scope>runtime</scope>
</dependency>
<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-webapp</artifactId>
<version>8.0.0.M2</version>
<scope>runtime</scope>
</dependency>
<dependency>
<groupId>org.gosu-lang.ronin</groupId>
<artifactId>ronin-init</artifactId>
<version>0.9.5-3</version>
<scope>runtime</scope>
</dependency>
<dependency>
<groupId>org.gosu-lang.ronin</groupId>
<artifactId>ronin-test</artifactId>
<version>0.9.5-3</version>
<scope>test</scope>
</dependency>
<dependency>
<groupId>org.seleniumhq.selenium</groupId>
<artifactId>selenium-java</artifactId>
<version>2.16.1</version>
<exclusions>
<exclusion>
<groupId>org.seleniumhq.selenium</groupId>
<artifactId>servlet-api-2.5</artifactId>
</exclusion>
</exclusions>
<scope>test</scope>
</dependency>
</dependencies>
<build>
<sourceDirectory>src</sourceDirectory>
<testSourceDirectory>test</testSourceDirectory>
<resources>
<resource>
<directory>src</directory>
<excludes>
<exclude>**/*.java</exclude>
</excludes>
</resource>
</resources>
<testResources>
<testResource>
<directory>test</directory>
<excludes>
<exclude>**/*.java</exclude>
</excludes>
</testResource>
</testResources>
<plugins>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-jar-plugin</artifactId>
<configuration>
<archive>
<manifest>
<addDefaultImplementationEntries>true</addDefaultImplementationEntries>
</manifest>
<manifestEntries>
<Contains-Sources>gs, gsx, gst</Contains-Sources>
</manifestEntries>
</archive>
</configuration>
</plugin>
<plugin>
<groupId>org.gosu-lang</groupId>
<artifactId>maven-gosu-plugin</artifactId>
<configuration>
<gosuVersion>0.9-12</gosuVersion>
</configuration>
</plugin>
</plugins>
</build>
</project>
Jump to Line
Something went wrong with that request. Please try again.