Database adapter for ext/sqlsrv #1264

Closed
dzuelke opened this Issue Apr 19, 2010 · 6 comments

Comments

Projects
None yet
1 participant
Contributor

dzuelke commented Apr 19, 2010

Windows only. Has some encoding problems; error messages are always in the system codepage, even if the connection is configured to use UTF-8 as the character set.

Contributor

dzuelke commented Apr 19, 2010

(In 064084c) from 5523393 to 39d1795 (from david-azure): ext/sqlsrv database adapter, closes #1264; IIS7 support, closes #1265; AgaviWindowsazureSessionStorage, closes #1266

Contributor

dzuelke commented Apr 19, 2010

Issue closed

Contributor

dzuelke commented Apr 23, 2010

(In 18a1563) fix version info from 064084c, refs #1264, #1266

Contributor

dzuelke commented Aug 8, 2010

Sample config:

<?xml version="1.0" encoding="UTF-8"?>
<ae:configurations xmlns:ae="http://agavi.org/agavi/config/global/envelope/1.0" xmlns="http://agavi.org/agavi/config/parts/databases/1.0">

    <ae:configuration>
        <databases default="mssql">

            <database name="mssql" class="AgaviSqlsrvDatabase">
                <ae:parameter name="server_name">WIN-6FQ74S4Q0N6\SQLEXPRESS</ae:parameter>
                <ae:parameter name="connection_info">
                    <ae:parameter name="UID">sa</ae:parameter>
                    <ae:parameter name="PWD">foobar</ae:parameter>
                    <ae:parameter name="Database">DevelopmentStorageDb200909191</ae:parameter>
                    <ae:parameter name="CharacterSet">UTF-8</ae:parameter>
                </ae:parameter>
            </database>

        </databases>
    </ae:configuration>

</ae:configurations>
Contributor

dzuelke commented Aug 8, 2010

(In 23c1f9e) handle error charset fixes in ext/sqlsrv v2, refs #1264

This was referenced Apr 19, 2010

dzuelke was assigned Jan 16, 2014

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment