Skip to content
master
Go to file
Code

Latest commit

 

Git stats

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
 
 
lib
 
 
 
 
 
 
 
 
 
 
 
 

README.md

agms_php_lite

Agms Php Lite Library

Build Status Latest Stable Version Total Downloads Latest Unstable Version License

Requirements

PHP 5.1 and later.

Installation

Download the latest release. Then, include the agms.php file.

require_once('/path/to/agms_php_lite/agms.php');

Getting Started

Simple usage looks like:

Agms::setUsername('your username');
Agms::setPassword('your password');
$params = array(
    'TransactionType' => 'sale'
    'CCNumber' => '4111111111111111',
    'CC_exp_date' => '1220',
    'CVV' => 123,
    'Amount' => '20'
);
$response = Agms::process($params);
echo $response;

Documentation

Please see http://onlinepaymentprocessing.com/docs/ for up-to-date documentation.

Tests

In order to run tests first install PHPUnit via Composer:

composer update --dev

To run the test suite:

./vendor/bin/phpunit

About

AGMS PHP Lite Library

Resources

License

Packages

No packages published

Languages

You can’t perform that action at this time.