can't install on r14b04/r15b01 (mac os x) #281

Open
mkalita opened this Issue Jul 29, 2012 · 8 comments

Comments

Projects
None yet
8 participants
@mkalita

mkalita commented Jul 29, 2012

mkalita@air ~. /opt/erlang/r14b04/activate
mkalita@air ~ $  curl https://raw.github.com/agner/agner/master/scripts/oneliner.release | sh
(…)

==> agner.3uPQgw (compile)
Compiled src/agner_index.erl
ERROR: compile failed while processing /private/tmp/agner.3uPQgw: {'EXIT',
    {undef,
        [{rebar,get_jobs,
             [{config,"/private/tmp/agner.3uPQgw",
                  [{require_otp_vsn,"R14"},
                   {lib_dirs,["deps"]},
                   {escript_incl_apps,
                       [getopt,gproc,rebar,plists,gen_fsm2,jsx]},
                   {erl_opts,[{i,"deps"}]},
                   {rebar_plugins,[agner_rebar_plugin]},
                   local]}]},
         {rebar_base_compiler,run,4},
         {rebar_erlc_compiler,doterl_compile,3},
         {rebar_erlc_compiler,compile,2},
         {rebar_core,run_modules,4},
         {rebar_core,execute,4},
         {rebar_core,process_dir,4},
         {rebar_core,process_commands,1}]}}
make: *** [compile] Error 1
mkalita@air ~ $ rebar -V
rebar 3.0.0 R14B04 20120729_155733 git 2.0.0-120-g4875d23

same thing on r15b01

@jbothma

This comment has been minimized.

Show comment
Hide comment
@jbothma

jbothma Aug 6, 2012

Same for me on OS X 10.6.8 and with kerl-installed r15b01

agner installation calls the rebar that it downloads during installation

$ make -n
./rebar compile
...

which is

$ ./rebar -V
rebar version: 2 date: 20120409_025958 vcs: git 6ada1c2

replacing the local rebar with a recent one seems to let make finish, but the next step,

./agner install agner

fails with the same problem because it probably installs the old rebar and uses that.

jbothma commented Aug 6, 2012

Same for me on OS X 10.6.8 and with kerl-installed r15b01

agner installation calls the rebar that it downloads during installation

$ make -n
./rebar compile
...

which is

$ ./rebar -V
rebar version: 2 date: 20120409_025958 vcs: git 6ada1c2

replacing the local rebar with a recent one seems to let make finish, but the next step,

./agner install agner

fails with the same problem because it probably installs the old rebar and uses that.

@maaku

This comment has been minimized.

Show comment
Hide comment
@maaku

maaku Sep 20, 2012

Same issue on OS 10.7.4 and r15b02 using commit 65de1cc (latest).

maaku commented Sep 20, 2012

Same issue on OS 10.7.4 and r15b02 using commit 65de1cc (latest).

@erikmack

This comment has been minimized.

Show comment
Hide comment
@erikmack

erikmack Oct 3, 2012

Reproduced on Gentoo, including all of jbothma's steps. On R15B01

erikmack commented Oct 3, 2012

Reproduced on Gentoo, including all of jbothma's steps. On R15B01

@zenweasel

This comment has been minimized.

Show comment
Hide comment
@zenweasel

zenweasel Oct 25, 2012

Same issue with OSX 10.8, both with oneliner and compiling from source.

Same issue with OSX 10.8, both with oneliner and compiling from source.

@Nek

This comment has been minimized.

Show comment
Hide comment
@Nek

Nek Oct 26, 2012

Same on OS 10.7.4 and r15b02 both for release and head version one liners

Nek commented Oct 26, 2012

Same on OS 10.7.4 and r15b02 both for release and head version one liners

@yrashk

This comment has been minimized.

Show comment
Hide comment
@yrashk

yrashk Oct 26, 2012

Member

I suggest migrating to expm (http://expm.co), a new incarnation of package management for Erlang (and other BEAM languages)... sort of like Agner 2 (http://rashkovskii.com/2012/10/01/expm-or-meet-agner-2/).

It doesn't have as many packages yet, but eventually it will :-)

Member

yrashk commented Oct 26, 2012

I suggest migrating to expm (http://expm.co), a new incarnation of package management for Erlang (and other BEAM languages)... sort of like Agner 2 (http://rashkovskii.com/2012/10/01/expm-or-meet-agner-2/).

It doesn't have as many packages yet, but eventually it will :-)

@Nek

This comment has been minimized.

Show comment
Hide comment
@Nek

Nek Oct 26, 2012

Thanks for direction 😄

Nek commented Oct 26, 2012

Thanks for direction 😄

@doppioslash

This comment has been minimized.

Show comment
Hide comment
@doppioslash

doppioslash Nov 1, 2012

Also on Ubuntu 12.10 same issue

Also on Ubuntu 12.10 same issue

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment