install doesn't support conditional versions #30

Closed
yrashk opened this Issue Jan 29, 2011 · 1 comment

Comments

Projects
None yet
1 participant
Owner

yrashk commented Jan 29, 2011

For example, atleast:2.0 will result in this:

=ERROR REPORT==== 31-Jan-2011::09:41:35 === *\* Generic server <0.73.0> terminating *\* Last message in was {clone,#Fun} *\* When Server state == {state,"rebar",no_such_version,undefined,undefined} *\* Reason for termination == *\* {function_clause,[{agner_repo_server,version_to_ref,[no_such_version]}, {agner_repo_server,'-handle_call/3-fun-1-',2}, {agner_repo_server,handle_call,3}, {gen_server,handle_msg,5}, {proc_lib,init_p_do_apply,3}]} escript: exception exit: {{{function_clause, [{agner_repo_server,version_to_ref,[no_such_version]}, {agner_repo_server,'-handle_call/3-fun-1-',2}, {agner_repo_server,handle_call,3}, {gen_server,handle_msg,5}, {proc_lib,init_p_do_apply,3}]}, {gen_server,call, [<0.73.0>,{clone,#Fun}]}}, {gen_server,call, [agner_server,{spec,"rebar",no_such_version}]}}
Owner

yrashk commented Feb 1, 2011

Done

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment