Skip to content
Browse files

Fixed setup.py to support requirements

  • Loading branch information...
1 parent b59280d commit 8a08f540231774870757b9b625eaf09feb84a9af @vbabiy vbabiy committed Jun 7, 2011
Showing with 5 additions and 0 deletions.
  1. +1 −0 MANIFEST.in
  2. 0 requirement.txt → requirements.txt
  3. +4 −0 setup.py
View
1 MANIFEST.in
@@ -1,2 +1,3 @@
include *.rst
+include requirements.txt
recursive-include scripts *
View
0 requirement.txt → requirements.txt
File renamed without changes.
View
4 setup.py
@@ -3,6 +3,9 @@
except ImportError:
from distutils.core import setup
+requirements = [r for r in map(str.strip, open('requirements.txt').readlines())]
+
+
setup(
name='chai',
version='0.1.8',
@@ -14,6 +17,7 @@
description="Easy to use mocking/stub framework.",
long_description=open('README.rst').read(),
keywords=['python', 'test', 'mock'],
+ install_requires=requirements,
classifiers=[
'Development Status :: 4 - Beta',
'License :: OSI Approved :: BSD License',

0 comments on commit 8a08f54

Please sign in to comment.
Something went wrong with that request. Please try again.