make jQuery plugin compatible with jQuery.noConflict(); #2

Closed
istrasoft opened this Issue Nov 17, 2013 · 2 comments

Projects

None yet

2 participants

@istrasoft

Wrap jQuery plugin in anonymous function and pass jQuery object. This makes it compatible with jQuery.noConflict();

@jletourneau
Contributor

Sorry I didn't notice your comment sooner! Working on a fix now; should be ready very shortly.

@istrasoft

Thanks ! I was also thinking that it would be wonderful if there was also a prompt version, this way there would be a full replacement for alert, prompt and confirm.

Maybe actually do a general base dialog where the buttons list and captions would be an option, and the confirm, alert and prompt would just be special cases.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment