Skip to content
This repository
tree: 91f123a583
Fetching contributors…

Octocat-spinner-32-eaf2f5

Cannot retrieve contributors at this time

file 73 lines (59 sloc) 1.44 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72
## main.gemspec
#

Gem::Specification::new do |spec|
  spec.name = "main"
  spec.version = "4.7.3"
  spec.platform = Gem::Platform::RUBY
  spec.summary = "main"
  spec.description = "description: main kicks the ass"

  spec.files =
["LICENSE",
 "README",
 "README.erb",
 "Rakefile",
 "TODO",
 "lib",
 "lib/main",
 "lib/main.rb",
 "lib/main/cast.rb",
 "lib/main/dsl.rb",
 "lib/main/factories.rb",
 "lib/main/getoptlong.rb",
 "lib/main/logger.rb",
 "lib/main/mode.rb",
 "lib/main/parameter.rb",
 "lib/main/program",
 "lib/main/program.rb",
 "lib/main/program/class_methods.rb",
 "lib/main/program/instance_methods.rb",
 "lib/main/softspoken.rb",
 "lib/main/stdext.rb",
 "lib/main/test.rb",
 "lib/main/usage.rb",
 "lib/main/util.rb",
 "main.gemspec",
 "samples",
 "samples/a.rb",
 "samples/b.rb",
 "samples/c.rb",
 "samples/d.rb",
 "samples/e.rb",
 "samples/f.rb",
 "samples/g.rb",
 "samples/h.rb",
 "samples/j.rb",
 "test",
 "test/main_test.rb"]

  spec.executables = []
  
  spec.require_path = "lib"

  spec.test_files = nil

  
    spec.add_dependency(*["fattr", "~> 2.2.0"])
  
    spec.add_dependency(*["map", "~> 4.3.0"])
  
    spec.add_dependency(*["arrayfields", "~> 4.7.4"])
  
    spec.add_dependency(*["chronic", "~> 0.6.2"])
  

  spec.extensions.push(*[])

  spec.rubyforge_project = "codeforpeople"
  spec.author = "Ara T. Howard"
  spec.email = "ara.t.howard@gmail.com"
  spec.homepage = "https://github.com/ahoward/main"
end
Something went wrong with that request. Please try again.