This repository has been archived by the owner. It is now read-only.

Not compatible with nodebb 1.0.0 #17

Closed
Nisthar opened this Issue Mar 3, 2016 · 11 comments

Comments

Projects
None yet
5 participants
@Nisthar
Copy link

Nisthar commented Mar 3, 2016

Hi,

I just tried to upgrade my app and i want to report that its not compatible with nodebb 1.0.0. I got an error remote: This looks like a new installation, so you'll have to answer a few questions about your environment before we ca n proceed. remote: Press enter to accept the default setting (shown in brackets). remote: remote: 2/3 23:57 [152461] - info: Now configuring mongo database: remote: Configuration Saved OK remote: 2/3 23:57 [152461] - error: Unable to initialize MongoDB! Is MongoDB installed? Error :Cannot find module 'conne ct-mongo/es5' remote: 2/3 23:57 [152461] - warn: NodeBB Setup Aborted. remote: Error: Cannot find module 'connect-mongo/es5' remote: at Function.Module._resolveFilename (module.js:338:15) remote: at Function.Module._load (module.js:280:25) remote: at Module.require (module.js:364:17) remote: at require (module.js:380:17) remote: at Object.module.init (/var/lib/openshift/56d3d2e189f5cfad110001a1/app-root/runtime/repo/src/database/mongo. js:55:20) remote: at /var/lib/openshift/56d3d2e189f5cfad110001a1/app-root/runtime/repo/src/install.js:180:25 remote: at /var/lib/openshift/56d3d2e189f5cfad110001a1/app-root/runtime/repo/src/install.js:555:3 remote: at Object.oncomplete (fs.js:108:15)

when the automatic setup is ran after installation.

@theunknownartisthour

This comment has been minimized.

Copy link

theunknownartisthour commented Mar 4, 2016

Looks like it didn't find the package to handle mongodb? Maybe the update changed to a different package to handle the database. Try sshing in and running npm install.

@Nisthar

This comment has been minimized.

Copy link

Nisthar commented Mar 4, 2016

@theunknownartisthour Yes. Think so

Good thing i had a snapshot saved. Otherwise, I may have lost of all my users data.

@ahwayakchih

This comment has been minimized.

Copy link
Owner

ahwayakchih commented Mar 4, 2016

Nodejs cartridge does run npm install when new build is being made.

I'll test upgrading to 1.0 next week.

@ahwayakchih ahwayakchih added the bug label Mar 5, 2016

@ahwayakchih

This comment has been minimized.

Copy link
Owner

ahwayakchih commented Mar 7, 2016

I can confirm that upgrading is broken. I got different errors, but some of them related to lack of ./nodebb upgrade and some of them caused by bugs in NodeBB 1.x.x.

@Nisthar

This comment has been minimized.

Copy link

Nisthar commented Mar 7, 2016

@ahwayakchih I thought there were no bugs in their releases. Thought only master branch contains bugs.
Did this mean that it will take some time to fix this?

@ahwayakchih

This comment has been minimized.

Copy link
Owner

ahwayakchih commented Mar 7, 2016

@Nisthar some of the bugs are already fixed, but i still see installation freezing, so don't know... I'll try again on or after next weekend and see if it works then.

@Nisthar

This comment has been minimized.

Copy link

Nisthar commented Mar 7, 2016

@ahwayakchih Ok 👍

@ahwayakchih

This comment has been minimized.

Copy link
Owner

ahwayakchih commented Mar 14, 2016

@Nisthar i've tested upgrade once again. Unfortunately it stops with Error: schema-out-of-date, even though i installed latest 0.9.x first and then updated to 1.x.x.

Clean 1.x.x installation works fine.

@enoughtoo

This comment has been minimized.

Copy link
Contributor

enoughtoo commented Apr 19, 2016

@ahwayakchih , first thank you for this comprehensive tutorial, it is definitely a time-saver. I just want to provide the feedback of following it to do a fresh install.
I have tried to do a clean install 1.0.3 with your tutorial. Unfortunately this doesn't work. I am using MongoLab cloud DB and it abort the nodebb setup with msg "Mongo returned the following error: Authentication failed.". I tried with 0.9.x installation, it works only with original Nodejs010 cartridges. The updated nodejs repository in the tutorial will break the installation with msg of port not available. So by now I will keep using old 0.9.x and original nodejs cartridge, wait for the future upgrade.

@N-kay

This comment has been minimized.

Copy link

N-kay commented Jul 3, 2016

@enoughtoo I just installed NodeBB v1.0.3 on OpenShift with a custom domain using this guide and repo without any problems. Afaik it should only be the upgrading from v0.9.x causing problems.

@ahwayakchih

This comment has been minimized.

Copy link
Owner

ahwayakchih commented Mar 15, 2018

Thanks everyone.

OpenShift changed and i no longer work on this project. If anyone wants to maintain it, let me know.

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.