Permalink
Browse files

Don't require all libraries in global Gemfile to clean tests

  • Loading branch information...
1 parent ca42ea1 commit 4d8e82987a3288303b50494209bea5aa6455711f @ai committed Jun 24, 2012
Showing with 13 additions and 11 deletions.
  1. +11 −11 Gemfile
  2. +2 −0 r18n-rails/spec/app/config/initializers/r18n.rb
View
22 Gemfile
@@ -3,22 +3,22 @@ source :rubygems
gem 'rspec'
gem 'rake'
-gem 'kramdown'
-gem 'RedCloth'
-gem 'sinatra'
-gem 'i18n'
-gem 'rails'
-gem 'rspec-rails'
+gem 'kramdown', :require => false
+gem 'RedCloth', :require => false
+gem 'sinatra', :require => false
+gem 'i18n', :require => false
+gem 'rails', :require => false
+gem 'rspec-rails', :require => false
gem 'sqlite3', :platform => [:ruby, :mswin, :mingw]
gem 'activerecord-jdbcsqlite3-adapter', :platform => :jruby
gem 'r18n-core', :path => 'r18n-core/'
-gem 'r18n-rails-api', :path => 'r18n-rails-api/'
-gem 'r18n-rails', :path => 'r18n-rails/'
+gem 'r18n-rails-api', :path => 'r18n-rails-api/', :require => false
+gem 'r18n-rails', :path => 'r18n-rails/', :require => false
group :development do
- gem 'yard'
- gem 'redcarpet'
- gem 'rbench'
+ gem 'yard', :require => false
+ gem 'redcarpet', :require => false
+ gem 'rbench', :require => false
end
@@ -0,0 +1,2 @@
+# Fix R18n Rails require, because it doesn’t require in global Gemfile.
+require 'r18n-rails'

0 comments on commit 4d8e829

Please sign in to comment.