New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Why python >= 3.5.3 ? #14

Closed
NotSqrt opened this Issue Oct 27, 2017 · 4 comments

Comments

Projects
None yet
3 participants
@NotSqrt

NotSqrt commented Oct 27, 2017

Hi,

Is there a reason for the python_requires='>=3.5.3' ?
Python 3.5.2 is the default for ubuntu LTS 16.04 for instance.

Was there a fix in python between 3.5.2 and 3.5.3 ?

Thanks !

@asvetlov

This comment has been minimized.

Member

asvetlov commented Oct 27, 2017

In 3.5.3 asyncio.get_event_loop() always returns a running event loop instance.
It's crucial for working with implicit loop only.
Could deadsnakes https://launchpad.net/~fkrull/+archive/ubuntu/deadsnakes satisfy your needs?
It allows to setup even Python 3.6 AFAIK

@kxepal

This comment has been minimized.

Member

kxepal commented Oct 27, 2017

Indeed it provides Python 3.6.

@NotSqrt

This comment has been minimized.

NotSqrt commented Oct 27, 2017

Too bad that deadsnakes does not provide python 3.5.3 or 3.5.4 for Xenial ..

Thanks for the explanation.

@NotSqrt NotSqrt closed this Oct 27, 2017

@asvetlov

This comment has been minimized.

Member

asvetlov commented Oct 27, 2017

I pretty sure you can run your project on Python 3.6 without issues (or in worst case it takes a half hour for migration).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment