Permalink
Browse files

test fixes

  • Loading branch information...
1 parent 578811b commit 9a6c81f3f40a3cc8277d01bc032bbf0809032845 @shime shime committed Aug 30, 2012
Showing with 3 additions and 3 deletions.
  1. +2 −2 features/step_definitions/rails_application_steps.rb
  2. +1 −1 test/notice_test.rb
@@ -27,14 +27,14 @@
@terminal.run(%{ruby -rrubygems -rthread -e "#{load_rails.strip!}" #{rails_create_command} rails_root})
if rails_root_exists?
- @terminal.echo("Generated a Rails #{version_string} application")
+ @terminal.echo("Generated a Rails #{version_string.strip} application")
else
raise "Unable to generate a Rails application:\n#{@terminal.output}"
end
require_thread
if version_string >= "3.1.0"
When %{I configure my application to require the "therubyracer" gem with version "0.10.1"}
- elsif version_string == "2.3.14"
+ elsif version_string =~ /2.3.14/
monkeypatch_old_version
end
config_gem_dependencies unless rails3
View
@@ -61,7 +61,7 @@ def assert_serializes_hash(attribute)
end
def assert_valid_notice_document(document)
- xsd_path = File.join(File.dirname(__FILE__), "airbrake_2_2.xsd")
+ xsd_path = File.join(File.dirname(__FILE__), "airbrake_2_3.xsd")
schema = Nokogiri::XML::Schema.new(IO.read(xsd_path))
errors = schema.validate(document)
assert errors.empty?, errors.collect{|e| e.message }.join

0 comments on commit 9a6c81f

Please sign in to comment.