Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Javascript support

mmcdaris edited this page · 12 revisions

The Airbrake JavaScript notifier is no longer included as a part of the Airbrake gem as of v4.0.0.

If you are upgrading your airbrake gem to a version greater or equal to 4.0.0:
Please Remove <%= airbrake_javascript_notifier %> from your code

We recommend you integrate our standalone JavaScript notifier into your frontend code separate from this gem.

Typical notifier setup looks like:

<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js"></script>
<script src="airbrake-shim.js" data-airbrake-project-id="FIXME" data-airbrake-project-key="FIXME" data-airbrake-environment-name="production"></script>
<script src="app.js"></script>

Please see the airbrake/airbrake-js repo for more instructions and customizations!

Something went wrong with that request. Please try again.