Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

i can't install #17

Open
EvoRongda opened this issue Dec 10, 2018 · 17 comments
Open

i can't install #17

EvoRongda opened this issue Dec 10, 2018 · 17 comments

Comments

@EvoRongda
Copy link

@EvoRongda EvoRongda commented Dec 10, 2018

root@kali:/mdk4-master# make
Makefile:13: *** Recursive variable 'PREFIX' references itself (eventually). Stop.
root@kali:
/mdk4-master#

@EvoRongda

This comment has been minimized.

Copy link
Author

@EvoRongda EvoRongda commented Dec 10, 2018

now work. I deleted space from line 13,14,15 and i press TAB. and now i have this error
dumpfile.c:2:10: fatal error: pcap.h: No such file or directory
#include <pcap.h>
^~~~~~~~
compilation terminated.
make[1]: *** [: dumpfile.o] Error 1
make[1]: Leaving directory '/root/mdk4-master/src'
make: *** [Makefile:10: all] Error 2

Edit: Now i have
"make[1]: *** [: dumpfile.o] Error 1
make[1]: Leaving directory '/root/mdk4-master/src'
make: *** [Makefile:10: all] Error 2
"
here i don't know how modify

@rattzy

This comment has been minimized.

Copy link

@rattzy rattzy commented Dec 30, 2018

I`m unable to find the folder mdk4-master after I follow the installation steps:
after this command: apt-get install pkg-config libnl-3-dev libnl-genl-3-dev I get the syntax: Reading package lists... Done
Building dependency tree
Reading state information... Done
libnl-3-dev is already the newest version (3.4.0-1).
libnl-genl-3-dev is already the newest version (3.4.0-1).
pkg-config is already the newest version (0.29-4+b1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

And after that, when I press cd /mdk4-master I got this:
bash: cd: /mdk4-master: No such file or directory.
I even searched in my computer for mdk4 and unable to find anything.

@samueloph

This comment has been minimized.

Copy link
Contributor

@samueloph samueloph commented Jan 5, 2019

@EvoRongda the first problem you mentioned was a regression that appeared on the last commit and I already created a PR to fix that (#16).

The second problem (pcap.h: No such file or directory) is because you also have to install libpcap-dev, I'm doing a PR to add this to README right now.

Please note that, if it solves your problem, you can install mdk4 using apt (apt install mdk4) if you're running Debian Testing or Kali Linux.

@strasharo

This comment has been minimized.

Copy link

@strasharo strasharo commented Jan 13, 2019

Also getting the same exception:

[user@host mdk4]$ make
Makefile:13: *** Recursive variable 'PREFIX' references itself (eventually).  Stop.
[user@host mdk4]$ 

#16 resolved the issue for me.

@v-borges

This comment has been minimized.

Copy link

@v-borges v-borges commented Feb 22, 2019

@rattzy, you should also clone the repo in order to get the mdk4 files:
git clone https://github.com/aircrack-ng/mdk4.git

Anyway, i'm getthing the same error:

root@raspberrypi:/home/pi/mdk4# make
Makefile:13: *** Recursive variable 'PREFIX' references itself (eventually).  Stop. 

This solution also fixed the make for me.

But i get another error on make install:

make[2]: Entering directory '/home/pi/mdk4/src/attacks'
make[2]: Nothing to be done for 'all'.
make[2]: Leaving directory '/home/pi/mdk4/src/attacks'
make[1]: Leaving directory '/home/pi/mdk4/src'
PREFIX:=/usr/local make -C src install
/bin/sh: 1: PREFIX:=/usr/local: not found
Makefile:13: recipe for target 'install' failed
make: *** [install] Error 127

Should I open another issue?

@strasharo

This comment has been minimized.

Copy link

@strasharo strasharo commented Feb 24, 2019

Same here on latest Kali and Arch with make 4.2.1, guess a recent make upgrade broke it since it was working for me before at least on Kali.

@genericc

This comment has been minimized.

Copy link

@genericc genericc commented Mar 16, 2019

yes on new kali 2019 got same error 127 cant install any idea?
make[2]: Entering directory '/home/pi/mdk4/src/attacks'
make[2]: Nothing to be done for 'all'.
make[2]: Leaving directory '/home/pi/mdk4/src/attacks'
make[1]: Leaving directory '/home/pi/mdk4/src'
PREFIX:=/usr/local make -C src install
/bin/sh: 1: PREFIX:=/usr/local: not found
Makefile:13: recipe for target 'install' failed
make: *** [install] Error 127

@genericc

This comment has been minimized.

Copy link

@genericc genericc commented Mar 16, 2019

on ubuntu 16.4 same

@BlackRNG

This comment has been minimized.

Copy link

@BlackRNG BlackRNG commented Mar 22, 2019

yes on new kali 2019 got same error 127 cant install any idea?
make[2]: Entering directory '/home/pi/mdk4/src/attacks'
make[2]: Nothing to be done for 'all'.
make[2]: Leaving directory '/home/pi/mdk4/src/attacks'
make[1]: Leaving directory '/home/pi/mdk4/src'
PREFIX:=/usr/local make -C src install
/bin/sh: 1: PREFIX:=/usr/local: not found
Makefile:13: recipe for target 'install' failed
make: *** [install] Error 127

Go to the Makefile at the line 13 and remove the ":" after PREFIX
Hope it works

@genericc

This comment has been minimized.

Copy link

@genericc genericc commented Mar 22, 2019

BlackRNG cool its works now thanks.

@genericc

This comment has been minimized.

Copy link

@genericc genericc commented Mar 22, 2019

i have 2 same Alfa Network AWUS036ACH adaptors but cant deauth client from router on 5 ghz band
can maybe someone help me with this issue?im trying about 1month and unfornately.

@Khwasi

This comment has been minimized.

Copy link

@Khwasi Khwasi commented Jul 3, 2019

like seriously no one can help with the installation of MDK4
Am stack after updating ma linux

@genericc

This comment has been minimized.

Copy link

@genericc genericc commented Jul 3, 2019

Khwasi i can help you for money if you very need run this script.for my work 100%

@Khwasi

This comment has been minimized.

Copy link

@Khwasi Khwasi commented Jul 3, 2019

hmmm please i have figured it out and it's working for me too 100%
tanks bro..

@Khwasi

This comment has been minimized.

Copy link

@Khwasi Khwasi commented Jul 3, 2019

who needs help am gonna help you for freeeee!!!!!!!!

@opulentweed710

This comment has been minimized.

Copy link

@opulentweed710 opulentweed710 commented Jul 16, 2019

Me please

@ARaimbekov

This comment has been minimized.

Copy link

@ARaimbekov ARaimbekov commented Nov 14, 2019

i cant dowloand the lib (apt-get install pkg-config libnl-3-dev libnl-genl-3-dev libpcap-dev) ,it is still varifiable?))

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
10 participants
You can’t perform that action at this time.