Permalink
Browse files

Better gem dependency definition, added ability for your Rakefile to …

…"require 'dataset'; load 'dataset.rake'"
  • Loading branch information...
1 parent 65069cc commit cfcb9fbe6e41173411c3a8ebb965bcd266aa9656 @aiwilliams committed Jun 12, 2009
Showing with 16 additions and 3 deletions.
  1. +2 −1 CHANGELOG
  2. +3 −0 Rakefile
  3. +8 −2 dataset.gemspec
  4. +3 −0 lib/dataset.rb
View
@@ -1,12 +1,13 @@
*1.3.0 [Rails 2.3.2] (??)
* Supporting Rails 2.3.2 [mhawkins, underlog]
+* Added tasks to load path so folks can require 'dataset.rake' [aiwilliams]
+* Updated gemspec to include dependencies [aiwilliams]
*1.2.0 [Cucumber] (April 8, 2009)
* Support for cucumber [jgarber, seancribbs]
-
*1.1.0 [STI, belongs_to] (February 14, 2009)
* STI is better supported for inserting, naming and finding records [aiwilliams]
View
@@ -19,6 +19,9 @@ begin
s.summary = 'A simple API for creating and finding sets of data in your database, built on ActiveRecord.'
s.email = 'adam@thewilliams.ws'
s.files = FileList["[A-Z]*", "{lib,tasks}/**/*", "plugit/descriptor.rb"].exclude("tmp")
+ s.require_paths = ["lib", "tasks"]
+ s.add_dependency('activesupport', '>= 2.3.0')
+ s.add_dependency('activerecord', '>= 2.3.0')
s.homepage = "http://github.com/aiwilliams/dataset"
s.description = s.summary
s.authors = ['Adam Williams']
View
@@ -6,12 +6,12 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Adam Williams"]
- s.date = %q{2009-04-14}
+ s.date = %q{2009-06-12}
s.description = %q{A simple API for creating and finding sets of data in your database, built on ActiveRecord.}
s.email = %q{adam@thewilliams.ws}
s.files = ["CHANGELOG", "LICENSE", "Rakefile", "README", "TODO", "VERSION.yml", "lib/dataset", "lib/dataset/base.rb", "lib/dataset/collection.rb", "lib/dataset/database", "lib/dataset/database/base.rb", "lib/dataset/database/mysql.rb", "lib/dataset/database/postgresql.rb", "lib/dataset/database/sqlite3.rb", "lib/dataset/extensions", "lib/dataset/extensions/cucumber.rb", "lib/dataset/extensions/rspec.rb", "lib/dataset/extensions/test_unit.rb", "lib/dataset/instance_methods.rb", "lib/dataset/load.rb", "lib/dataset/record", "lib/dataset/record/fixture.rb", "lib/dataset/record/meta.rb", "lib/dataset/record/model.rb", "lib/dataset/resolver.rb", "lib/dataset/session.rb", "lib/dataset/session_binding.rb", "lib/dataset/version.rb", "lib/dataset.rb", "tasks/dataset.rake", "plugit/descriptor.rb"]
s.homepage = %q{http://github.com/aiwilliams/dataset}
- s.require_paths = ["lib"]
+ s.require_paths = ["lib", "tasks"]
s.rubygems_version = %q{1.3.1}
s.summary = %q{A simple API for creating and finding sets of data in your database, built on ActiveRecord.}
@@ -20,8 +20,14 @@ Gem::Specification.new do |s|
s.specification_version = 2
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
+ s.add_runtime_dependency(%q<activesupport>, [">= 2.3.0"])
+ s.add_runtime_dependency(%q<activerecord>, [">= 2.3.0"])
else
+ s.add_dependency(%q<activesupport>, [">= 2.3.0"])
+ s.add_dependency(%q<activerecord>, [">= 2.3.0"])
end
else
+ s.add_dependency(%q<activesupport>, [">= 2.3.0"])
+ s.add_dependency(%q<activerecord>, [">= 2.3.0"])
end
end
View
@@ -1,3 +1,6 @@
+require 'activesupport'
+require 'activerecord'
+
require 'dataset/version'
require 'dataset/instance_methods'
require 'dataset/base'

0 comments on commit cfcb9fb

Please sign in to comment.