Skip to content

SyntaxError: Cannot declare a parameter named 'e' in strict mode #612

Closed
desoi opened this Issue Jan 10, 2012 · 5 comments

5 participants

@desoi
desoi commented Jan 10, 2012

The most recent build ("package" 2011-01-06) seems to have a problem with Safari (tested Mac 5.1.1). No error occurs when I switch to ace-uncompressed.js. No problems with recent Firefox versions.
@gissues:{"order":10.559006211180407,"status":"backlog"}

@firebase
firebase commented Feb 1, 2012

I'm also seeing this issue.

Safari: Version 5.1.2 (6534.52.7)
Mac OSX: 10.6.8

@amkirwan
amkirwan commented Feb 8, 2012

commenting out "use strict" on ace-uncompressed and then compressing removes the error on Safari

Safari: Version 5.1.3 (7534.53.10)
Mac OS X: 10.7.3

@nomadali

Can this be fixed in the original build ...

@amkirwan what utility do you use to compress ?

@amkirwan

I'm using RoR 3.1 which automatically minimizes assets. It uses the following gem to minimize js files.

https://github.com/lautis/uglifier

You can also use this package in Node

https://github.com/mishoo/UglifyJS

@nomadali

@amkirwan thanks!

@fjakobs fjakobs closed this Apr 6, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.