Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Narcissus produces syntax errors in IE8 or earlier #632

Closed
jamesmacaulay opened this Issue Jan 26, 2012 · 2 comments

Comments

Projects
None yet
2 participants

The version of Narcissus included with Ace uses JS property getters:

https://github.com/ajaxorg/ace/blob/master/lib/ace/narcissus/jsdefs.js#L602-604
https://github.com/ajaxorg/ace/blob/master/lib/ace/narcissus/jslex.js#L98-106

These produce syntax errors on unsupported platforms, including IE8 and earlier.
@gissues:{"order":1.8633540372673618,"status":"backlog"}

Contributor

fjakobs commented Apr 6, 2012

True but narcissus is only used inside of the web worker. Sine IE8 does not support workers I wonder how it can cause any errors?

@fjakobs fjakobs closed this Apr 6, 2012

Ah, okay that works. As long as it's never require'd and never parsed, then I guess there's nothing to worry about.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment